DirectShapeIsValidGeometry Method |
Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry
must make sense as a shape representation for the category assigned to this DirectShape object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidGeometry(
Solid Geom
)
Public Function IsValidGeometry (
Geom As Solid
) As Boolean
public:
bool IsValidGeometry(
Solid^ Geom
)
member IsValidGeometry :
Geom : Solid -> bool
Parameters
- Geom Solid
-
GeometryObject to be validated.
Return Value
Boolean
True if the supplied GeometryObject passes the validation criteria.
Exceptions
See Also