FamilyInstanceHostParameter Property |
If the instance is hosted by a wall, this property returns the parameter value of the insertion
point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double HostParameter { get; }
Public ReadOnly Property HostParameter As Double
Get
public:
property double HostParameter {
double get ();
}
member HostParameter : float with get
Property Value
Double
ExceptionsException | Condition |
---|
InvalidOperationException |
Only hosted instances whose family is not work plane based can support this functionality.
|
InvalidOperationException |
Only hosted instances of type Wall or in-place elements of category OST_Walls can support this functionality.
|
RemarksThis works for instances with a host element that is of type Wall or is in the OST_Walls category only,
including in-place ones.
See Also