RebarLayoutRule Enumeration |
The rule for how the rebars in rebar set are laid out
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RebarLayoutRule
Public Enumeration RebarLayoutRule
public enum class RebarLayoutRule
MembersMember name | Value | Description |
---|
Single | 0 |
It is a single rebar and not a rebar set.
|
FixedNumber | 1 |
The spacing between the rebar is adjustable,
but the number of bars is constant based on input.
|
MaximumSpacing | 2 |
The maximum distance between rebar is specified by input,
and the number of rebar changes based on the length of rebar set.
|
NumberWithSpacing | 3 |
Both the spacing between rebar and the number of rebar are constant based on input.
|
MinimumClearSpacing | 4 |
The minimum distance between rebar is specified by input,
and the number of rebar changes based on the length of rebar set.
This spacing is maintained even if the rebar size changes.
|
See Also