CurveElementType Enumeration |
An enumerated type listing the curve element types that can be used when filtering elements
(via CurveElementFilter).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum CurveElementType
Public Enumeration CurveElementType
public enum class CurveElementType
MembersMember name | Value | Description |
---|
Invalid | 0 |
An invalid curve element type.
|
ModelCurve | 1 |
A model curve.
|
DetailCurve | 2 |
A detail curve.
|
SymbolicCurve | 3 |
A symbolic curve.
|
ReferenceLine | 4 |
A reference line.
|
SpaceSeparation | 5 |
A space separation curve.
|
RoomSeparation | 6 |
An room separation curve.
|
AreaSeparation | 7 |
An area separation curve.
|
CurveByPoints | 8 |
A curve created by connecting a set of points.
|
RepeatingDetail | 9 |
The profile of a repeating detail set.
|
Insulation | 10 |
A detail curve representing insulation.
|
Cloud | 11 |
A portion of a revision cloud.
|
AreaBasedLoadBoundary | 12 |
An Area Based Load Boundary curve.
|
See Also