CompoundStructureGetDeckEmbeddingType Method |
Retrieves the deck embedding type used for the specified structural deck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic StructDeckEmbeddingType GetDeckEmbeddingType(
int layerIdx
)
Public Function GetDeckEmbeddingType (
layerIdx As Integer
) As StructDeckEmbeddingType
public:
StructDeckEmbeddingType GetDeckEmbeddingType(
int layerIdx
)
member GetDeckEmbeddingType :
layerIdx : int -> StructDeckEmbeddingType
Parameters
- layerIdx Int32
-
Index of a layer in the CompoundStructure.
Return Value
StructDeckEmbeddingType
The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.
Exceptions
See Also