ExtrusionAnalyzer Class

This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExtrusionAnalyzer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExtrusionAnalyzer : IDisposable

The ExtrusionAnalyzer type exposes the following members.

Properties
 NameDescription
Public propertyEndParameter The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public propertyExtrusionDirection The direction of extrusion specified for the extrusion analysis.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStartParameter The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Top
Methods
 NameDescription
Public methodCalculateFaceAlignment Calculates the alignment status of each face of the solid.
Public methodStatic memberCreate Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public methodDisposeReleases all resources used by the ExtrusionAnalyzer
Public methodGetExtrusionBase Obtains the face that represents the base contour of the extrusion analysis.
Top
Remarks

An instance of this class is a single-time use class which should be supplied a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the solid onto the input plane and along the extrusion direction.

After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.

This utility works best for geometry which are at least somewhat "extrusion-like", for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.

The ExtrusionAnalyzer expects only one single extrusion-like solid geometry. The ExtrusionAnalyzer does not support a Geometry containing multiple solids.

See Also