RebarConstraintGetTargetRebarEdgeNumber Method |
Returns the number of the edge on the other Rebar Element to which this RebarConstraint is attached.
The RebarConstraint must be of RebarConstraintType 'ToOtherRebar,' and the TargetRebarConstraintType
must be 'Edge'.
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetTargetRebarEdgeNumber()
Public Function GetTargetRebarEdgeNumber As Integer
public:
int GetTargetRebarEdgeNumber()
member GetTargetRebarEdgeNumber : unit -> int
Return Value
Int32
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarConstraint is not attached to an edge, or bend, or hook bend of another Rebar Element.
-or-
Constrained rebar isn't a shape driven rebar element.
|
See Also