BooleanOperationsUtilsCutWithHalfSpaceModifyingOriginalSolid Method

Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void CutWithHalfSpaceModifyingOriginalSolid(
	Solid solid,
	Plane plane
)

Parameters

solid  Solid
The input Solid to be cut. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
plane  Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.
Exceptions
ExceptionCondition
ArgumentException Thrown when the original solid object is the geometry of the Revit model.
ArgumentNullException A non-optional argument was NULL
Remarks
This operation modifies the original input Geometry objects.
See Also