PerformanceAdviserGetRuleId Method

Retrieves an id of a rule for a given index in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PerformanceAdviserRuleId GetRuleId(
	int index
)

Parameters

index  Int32
The index to retrieve the rule id for.

Return Value

PerformanceAdviserRuleId
The rule id.
Exceptions
ExceptionCondition
ArgumentException The index is outside of acceptable range.
See Also