FailureMessageAddResolution Method |
Adds a resolution for the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FailureMessage AddResolution(
FailureResolutionType type,
FailureResolution resolution
)
Public Function AddResolution (
type As FailureResolutionType,
resolution As FailureResolution
) As FailureMessage
public:
FailureMessage^ AddResolution(
FailureResolutionType type,
FailureResolution^ resolution
)
member AddResolution :
type : FailureResolutionType *
resolution : FailureResolution -> FailureMessage
Parameters
- type FailureResolutionType
-
The type of the resolution.
- resolution FailureResolution
-
The resolution.
Return Value
FailureMessage
The FailureMessage.
ExceptionsException | Condition |
---|
ArgumentException |
type is not a valid resolution type for this FailureMessage.
-or-
resolution of type is not valid for this FailureMessage.
-or-
This FailureMessage already contains a resolution of type type.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
This FailureMessage is already posted to a document
|
Remarks
Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition,
and could only be added once.
See Also