FailuresAccessorIsTransactionBeingCommitted Method |
Checks if the transaction for which failures are processed is being committed or rolled back.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsTransactionBeingCommitted()
Public Function IsTransactionBeingCommitted As Boolean
public:
bool IsTransactionBeingCommitted()
member IsTransactionBeingCommitted : unit -> bool
Return Value
Boolean
True if current transaction is being committed, false if the transaction is being rolled back.
Exceptions
Remarks
A transaction is considered as "being committed" if a caller has requested the transaction to be committed and
no previous failure processing operation requested the transaction to be rolled back.
See Also