ImageTypeStatus Enumeration |
Indicates the current state of the contents of the ImageType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ImageTypeStatus
Public Enumeration ImageTypeStatus
public enum class ImageTypeStatus
MembersMember name | Value | Description |
---|
Unknown | 0 |
The linked image has not yet been loaded. No image is available.
This status is only returned before the document is fully opened.
|
Loaded | 1 |
The linked image was successfully loaded.
|
FailedToLoad | 2 | The linked image could not be loaded from file.
Some possible reasons are:
- The file could not be found
- The file could be corrupt or not contain image data
- In case of PDF files, the file might be encrypted or not have the requested page
|
Unloaded | 3 |
The linked images was unloaded by the user. No image is available.
|
Imported | 4 |
The image was imported and is available.
|
Generated | 5 |
The internally created image is available.
|
See Also