UIDocumentSaveAndClose Method |
Close the document, prompting the user for saving it when necessary.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SaveAndClose()
Public Function SaveAndClose As Boolean
public:
bool SaveAndClose()
member SaveAndClose : unit -> bool
Return Value
BooleanFalse if closing procedure fails or if saving of a modified document was requested but failed.
Also returns False if closing is cancelled by an external application during 'DocumentClosing' event.
When function succeeds, True is returned.
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when attempting to close the currently active document.
Thrown if there are any transactions, sub-transactions or transaction groups which
were opened by the API code, and not closed. All of these items must be handled
before attempting to close the document.
|
InvalidOperationException | Thrown if this a linked file. |
RemarksUI dialogs may be shown during the call (e.g. when the document has been changed since last time it was saved) to get user responses.
The currently active document may not be closed by this function. It can only be closed via Revit's UI.
See Also