ReinforcementBarOrientation Enumeration |
Describes the bar orientation at Path Reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ReinforcementBarOrientation
Public Enumeration ReinforcementBarOrientation
public enum class ReinforcementBarOrientation
type ReinforcementBarOrientation
MembersMember name | Value | Description |
---|
TopOrExterior | 0 |
The major segment of the bar is on the top face (of a floor/slab) or the exterior face (of a wall).
|
NearSide | 1 |
The major segment of the bar is on the side edge near to the Path Reinforcement sketch line.
|
BottomOrInterior | 2 |
The major segment of the bar is on the bottom face (of a floor/slab) or the interior face (of a wall).
|
FarSide | 3 |
The major segment of the bar is on the side edge far from the Path Reinforcement sketch line.
|
See Also