RebarFreeFormAccessorGetHookPlaneNormalForBarIdx Method |
Returns the normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ GetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex
)
Public Function GetHookPlaneNormalForBarIdx (
end As Integer,
barPositionIndex As Integer
) As XYZ
public:
XYZ^ GetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex
)
member GetHookPlaneNormalForBarIdx :
end : int *
barPositionIndex : int -> XYZ
Parameters
- end Int32
-
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex Int32
-
An index between 0 and (NumberOfBarPositions-1).
Return Value
XYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Exceptions
See Also