ExtrusionAnalyzerFaceAlignment Enumeration |
Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ExtrusionAnalyzerFaceAlignment
Public Enumeration ExtrusionAnalyzerFaceAlignment
public enum class ExtrusionAnalyzerFaceAlignment
type ExtrusionAnalyzerFaceAlignment
MembersMember name | Value | Description |
---|
FullyAligned | 0 |
The face is fully aligned with faces of the extrusion.
|
PartiallyAligned | 1 |
The face is only partially aligned with faces of the extrusion.
|
Unaligned | 2 |
The face is not aligned with any faces of the extrusion.
|
See Also