CompoundStructureChangeRegionWidth Method |
Adjust the width of an existing simple region.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ChangeRegionWidth(
int regionId,
double newWidth
)
Public Function ChangeRegionWidth (
regionId As Integer,
newWidth As Double
) As Boolean
public:
bool ChangeRegionWidth(
int regionId,
double newWidth
)
member ChangeRegionWidth :
regionId : int *
newWidth : float -> bool
Parameters
- regionId Int32
-
The id of a region.
- newWidth Double
-
The desired width of the specified region.
Return Value
Boolean
True if newWidth is zero and the region was deleted.
Exceptions
Remarks
If width is changed to zero, the effect is to delete the region.
See Also