TaskDialogEnableMarqueeProgressBar Property

Enables a marquee style progress bar to be displayed in the TaskDialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool EnableMarqueeProgressBar { get; set; }

Property Value

Boolean
Exceptions
ExceptionCondition
InvalidOperationException Thrown if the TaskDialog also has ExtraCheckBoxText set as the two cannot coincide in the same TaskDialog.
Remarks

When true, the TaskDialog will display a progress bar that has an indeterminate start and stop.

A progress bar is a window that an application can use to indicate the progress of a lengthy operation.

It consists of a rectangle that is animated as an operation progresses. The animation continues until the TaskDialog is closed.

The default value is false.

See Also