FailuresAccessorReplaceFailures Method

Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ReplaceFailures(
	FailureMessage failure
)

Parameters

failure  FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.
Exceptions
ExceptionCondition
ArgumentException Severity of failure must be FailureSeverity::DocumentCorruption.
ArgumentNullException A non-optional argument was null
InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.
See Also