FamilyManagerIsParameterLocked Method

For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsParameterLocked(
	FamilyParameter familyParameter
)

Parameters

familyParameter  FamilyParameter
 

Return Value

Boolean
True if the parameter is lockable and is locked; false otherwise.
Exceptions
ExceptionCondition
InvalidOperationException Thrown if this family is not a Conceptual Mass or Curtain Panel family.
See Also