CompoundStructureCanLayerBeVariable Method |
Identifies if the input layer can be designated as a variable thickness layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanLayerBeVariable(
int variableLayerIndex
)
Public Function CanLayerBeVariable (
variableLayerIndex As Integer
) As Boolean
public:
bool CanLayerBeVariable(
int variableLayerIndex
)
member CanLayerBeVariable :
variableLayerIndex : int -> bool
Parameters
- variableLayerIndex Int32
-
Index of a layer in the CompoundStructure.
Return Value
Boolean
True if the input layer may be a variable thickness layer and false otherwise.
Remarks
A layer whose layer function is StructuralDeck may not be designated as a variable layer.
See Also