DoubleClickAction Enumeration |
Possible actions Revit can take in response to the user double-clicking on an element.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum DoubleClickAction
Public Enumeration DoubleClickAction
public enum class DoubleClickAction
MembersMember name | Value | Description |
---|
NoAction | 0 |
Double-clicks should be ignored.
|
EditFamily | 1 |
Double-click should open the family for editing.
|
EditType | 2 |
Double-click should take the user to the edit type dialog.
|
ActivateView | 3 |
Double-click should activate the view or schedule.
|
EnterEditMode | 4 |
Double-click will enter a specific edit mode for the element.
|
DeactivateView | 5 |
Double-click should deactivate the active view.
|
See Also