IndependentTagSetIsLeaderVisible Method |
Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetIsLeaderVisible(
Reference referenceTagged,
bool visible
)
Public Sub SetIsLeaderVisible (
referenceTagged As Reference,
visible As Boolean
)
public:
void SetIsLeaderVisible(
Reference^ referenceTagged,
bool visible
)
member SetIsLeaderVisible :
referenceTagged : Reference *
visible : bool -> unit
Parameters
- referenceTagged Reference
-
The reference which is tagged.
- visible Boolean
-
True for showing the leader, false to hide it.
ExceptionsException | Condition |
---|
ArgumentException |
The specified reference is not currently tagged.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The IndependentTag object does not have a tag behavior.
-or-
For this tag leaders are not allowed.
-or-
The LeadersPresentationMode should be set to ShowSpecificLeaders.
|
See Also