IFCCategoryTemplateIsValidName Method |
Returns result that the proposed name is valid and not exist in the specified document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidName(
Document document,
string name
)
Public Shared Function IsValidName (
document As Document,
name As String
) As Boolean
public:
static bool IsValidName(
Document^ document,
String^ name
)
static member IsValidName :
document : Document *
name : string -> bool
Parameters
- document Document
-
Document to check
- name String
-
Name to check.
Return Value
Boolean
Whether or not the name is valid.
Exceptions
Remarks
Name can't contains following characters, such as { } [ ] | ; < > ? ` ~ \ : \r \n \f \t \v.
Name can't be blank.
If true, the name is valid and not exist in specified document.
If false, the name is not a valid name which means it does not exist in specified document.
See Also