FailureMessageAccessorGetCurrentResolutionType Method |
Retrieves the type of resolution to be used to resolve the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FailureResolutionType GetCurrentResolutionType()
Public Function GetCurrentResolutionType As FailureResolutionType
public:
FailureResolutionType GetCurrentResolutionType()
member GetCurrentResolutionType : unit -> FailureResolutionType
Return Value
FailureResolutionType
The type of failure resolution to be used to resolve the failure.
ExceptionsException | Condition |
---|
InvalidOperationException |
This FailureMessageAccessor has not been properly initialized.
-or-
This FailureMessageAccessor does not have any resolutions.
|
Remarks
If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.
See Also