ParameterFilterElementElementFilterIsAcceptableForParameterFilterElement(ElementFilter) Method |
Checks that an ElementFilter is acceptable for use in defining the filtering rules
for a ParameterFilterElement (i.e., for view filtering).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ElementFilterIsAcceptableForParameterFilterElement(
ElementFilter elementFilter
)
Public Function ElementFilterIsAcceptableForParameterFilterElement (
elementFilter As ElementFilter
) As Boolean
public:
bool ElementFilterIsAcceptableForParameterFilterElement(
ElementFilter^ elementFilter
)
member ElementFilterIsAcceptableForParameterFilterElement :
elementFilter : ElementFilter -> bool
Parameters
- elementFilter ElementFilter
-
The ElementFilter to validate.
Return Value
Boolean
True if the ElementFilter is acceptable for use by an ParameterFilterElement, false if not.
Exceptions
Remarks
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter
representing a Boolean combination of ElementParameterFilters. In addition, we check that
each ElementParameterFilter satisfies the following conditions:
Its array of FilterRules is not empty and contains:
- Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
- Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
- Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and
the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.
See Also