PDFExportOptionsIsValidNamingRule Method

Whether naming rule is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidNamingRule(
	IList<TableCellCombinedParameterData> namingRule
)

Parameters

namingRule  IListTableCellCombinedParameterData
The naming rule to be validated.

Return Value

Boolean
Whether or not the name is valid.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
If true, this naming rule is a valid. If false, this naming rule is not valid for empty naming rule or illegal characters, such as
C#
\ / : * ? " < > |
.
See Also