CADLinkTypeReload(CADLinkOptions) Method |
Loads or reloads the link from its currently-stored location. If the link is an
external resource, Revit will contact the IExternalResourceServer to get the latest version
of the link.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LinkLoadResult Reload(
CADLinkOptions options
)
Public Function Reload (
options As CADLinkOptions
) As LinkLoadResult
public:
LinkLoadResult^ Reload(
CADLinkOptions^ options
)
member Reload :
options : CADLinkOptions -> LinkLoadResult
Parameters
- options CADLinkOptions
-
Options for reloading the link. Options include
the ability to preserve graphic overrides on reload.
Return Value
LinkLoadResult
An object containing the ElementId of the link
and an enum value indicating any
errors which occurred while trying to load.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This CADLinkType represents an import and cannot be used as a link.
-or-
The element "this CADLinkType" is in a read-only document.
|
RemarksIf the link is currently loaded, any changes made in-memory
to the link's shared coordinates will be discarded.
See Also