RebarShapeDrivenAccessorPitch Property

For a spiral, the pitch, or vertical distance traveled in one rotation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double Pitch { get; set; }

Property Value

Double
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: pitch must be positive.
InvalidOperationException This RebarShapeDrivenAccessor is not an instance of a spiral shape. -or- This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.
Remarks
Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.
See Also