TriangulatedSolidOrShellGetShellComponent Method |
Returns the specified shell component of a solid or shell. Input componentIndex must lie
between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent
should not be modified by the caller.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TriangulatedShellComponent GetShellComponent(
int componentIndex
)
Public Function GetShellComponent (
componentIndex As Integer
) As TriangulatedShellComponent
public:
TriangulatedShellComponent^ GetShellComponent(
int componentIndex
)
member GetShellComponent :
componentIndex : int -> TriangulatedShellComponent
Parameters
- componentIndex Int32
-
The component index, must be between 0 and ShellComponentCount – 1, inclusive.
Return Value
TriangulatedShellComponent
The component.
ExceptionsException | Condition |
---|
ArgumentException |
Shell component index componentIndex is out of range.
|
See Also