DocumentGetSpaceAtPoint(XYZ, Phase) Method |
Gets a space containing the point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Space GetSpaceAtPoint(
XYZ point,
Phase phase
)
Public Function GetSpaceAtPoint (
point As XYZ,
phase As Phase
) As Space
public:
Space^ GetSpaceAtPoint(
XYZ^ point,
Phase^ phase
)
member GetSpaceAtPoint :
point : XYZ *
phase : Phase -> Space
Parameters
- point XYZ
- Point to be checked.
- phase Phase
- Phase in which the space exists.
Return Value
SpaceThe space containing the point.
Exceptions
RemarksIf phase is , it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns .
See Also