SpatialFieldManagerGetMaximum Method |
Calculates the maximum value for all primitives
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetMaximum(
int resultIndex,
bool rawValue
)
Public Function GetMaximum (
resultIndex As Integer,
rawValue As Boolean
) As Double
public:
double GetMaximum(
int resultIndex,
bool rawValue
)
member GetMaximum :
resultIndex : int *
rawValue : bool -> float
Parameters
- resultIndex Int32
-
Index of result schema
- rawValue Boolean
-
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS
Return Value
Double
Resulting maximum value
ExceptionsException | Condition |
---|
InapplicableDataException |
Thrown when current measurement is >= the number of measurements for at least one primitive
|
See Also