RebarShapeDefinitionBySegmentsSetSegmentVariableDirection Method |
Remove the fixed direction from a segment.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSegmentVariableDirection(
int iSegment
)
Public Sub SetSegmentVariableDirection (
iSegment As Integer
)
public:
void SetSegmentVariableDirection(
int iSegment
)
member SetSegmentVariableDirection :
iSegment : int -> unit
Parameters
- iSegment Int32
-
Index of the segment (0 to NumberOfSegments - 1).
Exceptions
Remarks
The segment's angle will be allowed to vary, with a range of 90 degrees. The segment must have at least two constraints.
See Also