FabricationRodInfoSetRodEndPosition Method

Sets the position of the rod end. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetRodEndPosition(
	int rodIndex,
	XYZ position
)

Parameters

rodIndex  Int32
The index of the rod.
position  XYZ
The position of the rod end.
Exceptions
ExceptionCondition
ArgumentException Invalid rod position.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The hanger is not a bearer hanger.
See Also