RebarInSystemMoveBarInSet Method

This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void MoveBarInSet(
	int barPositionIndex,
	Transform moveTransform
)

Parameters

barPositionIndex  Int32
The bar index of the rebar to apply the transformation.
moveTransform  Transform
The transformation matrix to apply to the specified rebar bar.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
InapplicableDataException For this RebarInSystem element individual bars can't be moved, excluded or included.
See Also