ExternalResourceLoadContextGetCallingDocumentModelPath Method |
Returns a copy of the ModelPath of the document that is requesting
the external resource.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ModelPath GetCallingDocumentModelPath()
Public Function GetCallingDocumentModelPath As ModelPath
public:
ModelPath^ GetCallingDocumentModelPath()
member GetCallingDocumentModelPath : unit -> ModelPath
Return Value
ModelPath
A copy of the ModelPath of the document that is requesting the external
resource.
ExceptionsException | Condition |
---|
InvalidOperationException |
The document requesting the external resource does not have a ModelPath, either because
it is detached, or because it has not been saved to disk yet.
|
See Also