ScheduleDefinitionCanSortByField Method |
Checks whether a field can be used for sorting/grouping.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanSortByField(
ScheduleFieldId fieldId
)
Public Function CanSortByField (
fieldId As ScheduleFieldId
) As Boolean
public:
bool CanSortByField(
ScheduleFieldId^ fieldId
)
member CanSortByField :
fieldId : ScheduleFieldId -> bool
Parameters
- fieldId ScheduleFieldId
-
The ID of the field to check.
Return Value
Boolean
True if the field can be used for sorting/grouping, false otherwise.
Exceptions
Remarks
Schedules cannot be sorted/grouped by the Count field, Percentage
fields, or Formula fields that depend on Percentage fields because
those types of fields don't have meaningful values until after
sorting and grouping takes place.
See Also