PerformanceAdviserIsRuleEnabled(Int32) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsRuleEnabled(
	int index
)

Parameters

index  Int32
The rule index to retrieve enabled/disabled status for.

Return Value

Boolean
True if rule is disabled, false otherwise.
Exceptions
ExceptionCondition
ArgumentException The index is outside of acceptable range.
See Also