FreeFormElementCreate Method |
Creates a new FreeFormElement from a copy of the input geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FreeFormElement Create(
Document document,
Solid geometry
)
Public Shared Function Create (
document As Document,
geometry As Solid
) As FreeFormElement
public:
static FreeFormElement^ Create(
Document^ document,
Solid^ geometry
)
static member Create :
document : Document *
geometry : Solid -> FreeFormElement
Parameters
- document Document
-
The document in which the element is to be created.
- geometry Solid
-
The input geometry.
Return Value
FreeFormElement
returns a new FreeFormElement
ExceptionsException | Condition |
---|
ArgumentException |
document is not a family document, nor a document editing an in-place family.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also