FamilyInstanceGetReferences Method |
Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Reference> GetReferences(
FamilyInstanceReferenceType referenceType
)
Public Function GetReferences (
referenceType As FamilyInstanceReferenceType
) As IList(Of Reference)
public:
IList<Reference^>^ GetReferences(
FamilyInstanceReferenceType referenceType
)
member GetReferences :
referenceType : FamilyInstanceReferenceType -> IList<Reference>
Parameters
- referenceType FamilyInstanceReferenceType
-
The family reference type.
Return Value
IListReference
Returns all the family instance references corresponding to reference planes and reference lines of the given reference type.
Returns null if there are no family instance references of the given reference type, or if the input reference type is FamilyInstanceReferenceType.NotAReference.
Exceptions
Remarks
Reference planes from the instance's family that have their "Is Reference" property set to "Not a Reference" do not create references in the family instance.
See Also