StructuralConnectionHandlerOverrideTypeParams Property |
Allow or disallow connection's type parameters to be overridden.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool OverrideTypeParams { get; set; }
Public Property OverrideTypeParams As Boolean
Get
Set
public:
property bool OverrideTypeParams {
bool get ();
void set (bool value);
}
member OverrideTypeParams : bool with get, set
Property Value
Boolean
Remarks
When set to true, a set of instance parameters is created for this connection by copying the type parameter set and the user can change this instance parameters in order to make this connection different from the others of the same type.
Any further modification on type parameters will not affect this instance (until the "override" is turned back off).
When set to false the connection instance parameters are discarded and the type parameters are used again.
The default value of this parameter is false.
See Also