RebarCurvesDataCanAddBarGeometry Method |
If the layout rule is Singe or FixedNumber or NumberWithSpacing this function will return true if getNumberOfBarGeometry() is less getBarsNumber(), false otherwise.
If the layout rule is MaximumSpacing or MinimumClearSpacing this function will return always true.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanAddBarGeometry()
Public Function CanAddBarGeometry As Boolean
public:
bool CanAddBarGeometry()
member CanAddBarGeometry : unit -> bool
Return Value
Boolean
Returns true if we can add more bar geometry for the current layout, false otherwise.
See Also