FamilyManagerSetValueString Method |
Set the string value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetValueString(
FamilyParameter familyParameter,
string value
)
Public Sub SetValueString (
familyParameter As FamilyParameter,
value As String
)
public:
void SetValueString(
FamilyParameter^ familyParameter,
String^ value
)
member SetValueString :
familyParameter : FamilyParameter *
value : string -> unit
Parameters
- familyParameter FamilyParameter
- The family parameter of current type.
- value String
- The new value string for family parameter.
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when the input argument-"familyParameter" or "value"-is .
|
ArgumentException |
Thrown when the input argument-"familyParameter"-is an invalid family parameter.
or the input argument-"value"-is an illegal string.
|
ArgumentOutOfRangeException |
Thrown when the input argument-"familyParameter"-is out of range.
|
InvalidOperationException |
Thrown when the family parameter is determined by formula, or it is not a value type,
or the current family type is invalid.
|
See Also