DirectShapeSetOptions Method |
Sets the options to use for this DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetOptions(
DirectShapeOptions options
)
Public Sub SetOptions (
options As DirectShapeOptions
)
public:
void SetOptions(
DirectShapeOptions^ options
)
member SetOptions :
options : DirectShapeOptions -> unit
Parameters
- options DirectShapeOptions
-
Options to use for this DirectShape.
ExceptionsException | Condition |
---|
ArgumentException |
The DirectShapeOptions provided are not valid for this DirectShape.
-or-
The DirectShapeOptions provided are not valid for this transient DirectShape.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The new options take effect immediately.
If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence.
Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable
existing constraints applied to that object.
See Also