FabricationConnectorInfoBodyConnectorId Property |
Fabrication body connector Id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int BodyConnectorId { get; set; }
Public Property BodyConnectorId As Integer
Get
Set
public:
property int BodyConnectorId {
int get ();
void set (int value);
}
member BodyConnectorId : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: bodyConnectorId is invalid based on the shape and domain.
|
InvalidOperationException |
When setting this property: the connector cannot be modified on an owned fabrication part.
-or-
When setting this property: the connector is already connected.
-or-
When setting this property: the fabrication part is connected to more than one item.
|
Remarks
A reference to the fabrication configuration connectors.
Setting the connector value will also set the connector lock.
A value of 0 indicates the connector is set to none.
See Also