AnalyticalLinkTypeRotationZ Property

Fixity of rotation around Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalyticalFixityState RotationZ { get; set; }

Property Value

AnalyticalFixityState
Exceptions
ExceptionCondition
ArgumentException When setting this property: The fixity state rotationZ is not valid for Analytical Link Type parameters.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also