AnalyticalModelSelector(AnalyticalCurveSelector) Constructor

Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalyticalModelSelector(
	AnalyticalCurveSelector inCurveSelector
)

Parameters

inCurveSelector  AnalyticalCurveSelector
Portion of the analytical curve in which the client has interest.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
This version is useful for single-curve or single-point analytical models.
See Also