SolidCurveIntersectionMode Enumeration |
Represents the types of results available for calculating the intersection between a solid and a curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum SolidCurveIntersectionMode
Public Enumeration SolidCurveIntersectionMode
public enum class SolidCurveIntersectionMode
type SolidCurveIntersectionMode
MembersMember name | Value | Description |
---|
CurveSegmentsInside | 0 |
The results will include only curve segments inside the solid volume. This also will include curve segments coincident
with the face(s) of the volume.
|
CurveSegmentsOutside | 1 |
The results will include only curve segments outside the solid volume.
|
See Also