The detail level of this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ViewDetailLevel DetailLevel { get; set; }
Public Property DetailLevel As ViewDetailLevel
Get
Set
public:
property ViewDetailLevel DetailLevel {
ViewDetailLevel get ();
void set (ViewDetailLevel value);
}
member DetailLevel : ViewDetailLevel with get, set
Property Value
ViewDetailLevel
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Cannot set ViewDetailLevel to Unassigned
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
When setting this property: View does not have a Detail Level property
-or-
When setting this property: Detail Level cannot be modified.
|
See Also