Concrete Class

A static class that provides access to the property names that appear in the Concrete visual asset schema.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualConcrete

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Concrete

The Concrete type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCommonTintColor The property labeled "Tint Color" from the "Concrete" schema.
Public propertyStatic memberCommonTintToggle The property labeled "Tint" from the "Concrete" schema.
Public propertyStatic memberConcreteBmMap The property labeled "Image" from the "Concrete" schema.
Public propertyStatic memberConcreteBrightmode The property labeled "Weathering" from the "Concrete" schema.
Public propertyStatic memberConcreteBumpAmount The property labeled "Amount" from the "Concrete" schema.
Public propertyStatic memberConcreteBumpMap The property labeled "Image" from the "Concrete" schema.
Public propertyStatic memberConcreteColor The property labeled "Color" from the "Concrete" schema.
Public propertyStatic memberConcreteFinish The property labeled "Type" from the "Concrete" schema.
Public propertyStatic memberConcreteSealant The property labeled "Sealant" from the "Concrete" schema.
Top
See Also